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Abstract: Throughout the structural analysis process, the Conventional Method and the Software Base Method are the two 
approaches that are utilised to analyse the entire structure. In this article, the software base technique is explained. Since this 
strategy relies entirely on software, the field person needs to be proficient in using and comprehending the software. For the 
precision of structural analysis, Tekla software is selected. Numerous topics are covered in this article, including Tekla's 
Structural Analysis Workflow, Load Creation and Combinations, Analysis Model, Model Code, and more. 
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I. INTRODUCTION 
An integrated model-based 3D tool for multi-material structure analysis and design (of steel and concrete components) is Tekla 
Structural Designer. Interactive modeling, automated structural analysis and design, drawing, and report generation are some of the 
features. 
 
A. Multiple Design Codes are Supported 
1) ACI/AISC 
2) Eurocodes 
3) British Standards 
4) Indian Standards 
5) Australian Standards 
The goal is to enable you to create your model quickly, apply loads, and configure it for the right set of design forces. 
You can accomplish this on a daily basis without having to work with the underlying analytic models. You can instead concentrate 
on the finished design. Tekla Structural Designer does this by automatically generating and evaluating a number of solver models, 
each of which is based on a distinct but generally recognized methodology. 
You can be sure that every possibility has been considered because all of the solver models' forces have been taken into account 
during design. 
 
B. The Method of Operation for Tekla Structural Designer 
The phases of the conventional modeling, analysis, and design process are as follows: 
1) Provide a way to input or describe the model 
2) Analyze the model 
3) Design the model 
4) Produce calculations 
5) Produce drawings 

II. WORKFLOW 
A. Process 
1) Set the Load Modelling Code 
To set the load modeling code and to use the standard building code specific load combination factors: 
a) On the File menu, click Settings > Options, and go to the Load modeling settings. 
b) On the Current code tab, select a code from the Load modeling code list. 
c) Check the load combination factors on the appropriate tab. 
d) If you use the Eurocode, enter the reliability class factor, and select the formula to be used on the Eurocode tab. 
e) Click OK. 



International Journal for Research in Applied Science & Engineering Technology (IJRASET) 
                                                                                           ISSN: 2321-9653; IC Value: 45.98; SJ Impact Factor: 7.538 

                                                                                                                Volume 11 Issue XI Nov 2023- Available at www.ijraset.com 
     

 
1415 ©IJRASET: All Rights are Reserved | SJ Impact Factor 7.538 | ISRA Journal Impact Factor 7.894 | 

 

2) Create or Modify a load Group 
A load group can be created by changing the default load group or by creating a new group. The same methods that apply to the 
default load group also apply to any existing load group. 
Make sure the correct load modeling code is set in File menu > Settings > Options > Load modeling > Current code before you 
begin. 
a) On the Analysis & design tab, click Load groups. 
b) In the Load Groups dialog box, do one of the following: 
 Click Add to create a new load group. 
 Select the default load group from the list to modify it. 
 Select an existing load group from the list to modify it. 
c) Click the load group name to modify it. 
d) Click the load group type and select a type from the list. 
e) Click the load group direction to modify it. 
f) To indicate compatibility with existing load groups: 
 In the Compatible column, enter the number you have used for the load groups that are compatible with this load group. 
 In the Incompatible column, enter the number you have used for the load groups that are incompatible with this load group. 
g) Click the load group color and select a color from the list. Tekla Structures uses this color when it shows the loads of this load 

group in the model views. 
h) Click OK to close the dialog box. 
 
3) Define the Properties of Load 
Before you create a load, it is a good idea to define or check the load properties. 
a) On the Analysis & design tab, click Load properties, and then click a relevant load type. 
For example, click Area load to define area load properties. 
 
b) In the load properties dialog box: 
 Enter or modify the properties. 
 Select a load group. 
 Define the load magnitude, and the load form if needed. 
 Attach the load to a part or to a position. 
               You cannot attach a load to a part after you have created the load. 
               You can detach a load from a part after you have created the load. 
 Define the load-bearing parts. 
 If needed, adjust the loaded length or area. 
 If needed, modify the load distribution on the Load panel tab. 
 Click OK to save the properties. 
 
4) Creating Filters 
To choose which components to include in an analysis model, you can use a filter. To specify which of the included parts are 
regarded as braces or secondary analysis parts in the analysis model, you may also utilize filters. 
The following filters are available in the analysis model properties: 
a) Analysis model filter 
b) Bracing member filter 
c) Secondary member filter 
 
Tekla Structures saves the settings with the properties of the analysis model, and these filters are based on selection filters. This 
implies that you can verify the standards by which you chose the things. 
When you create new objects in the physical model, Tekla Structures automatically adds them to the analysis model if they meet the 
requirements of the analysis model filter and analysis model content. 
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5) Objects Included in Analysis Model 
You can define which objects to include in an analysis model. Tekla Structures includes or ignores some objects automatically. 
The following factors affect which objects Tekla Structures includes in analysis models: 
 Analysis model filter 
 Analysis model content 
 Which objects you select, add, remove, or ignore manually 
Tekla Structures ignores the following objects in the analysis, even if you have included them in an analysis model: 
 Parts and loads that are filtered out 
 Component objects, such as minor parts, bolts, and reinforcing bars 
 Parts whose analysis class is Ignore 
 Parts whose analysis part has been deleted 
The following components set the analysis properties of the parts they create, so these parts are included in analysis models: 
 Shed (S57) 
 Building (S58) and (S91) 
 Slab generation (61) and (62) 
 Truss (S78) 
To make sure the columns are aligned, we advise you to start with just columns in the analysis model. 
 
6) Create an Analysis Model 
Tekla Structures offers multiple ways to build an analysis model. 
You can build an analytical model with all of the parts and loads from your physical model, or you can limit it to just the parts and 
loads you want. A modal analysis model can be created, or you can make a new analysis model by copying an existing one. 
First, we advise you to make sure the columns in the analysis model are aligned and only include columns. Next, add main beams 
and additional components as required. 
a) On the Analysis & design tab, click A & D models to open the Analysis & Design Models dialog box. 
b) Click New to open the Analysis Model Properties dialog box. 
c) On the Analysis model tab, select the analysis application you want to use from the Analysis application list. 
d) Enter a unique name for the analysis model. 
For example, you can use a name that describes the portion of the physical model you want to analyze. 
 
e) To make the analysis model more accurate, select an option for the following filters: 
 Analysis model filter 
 Bracing member filter 
 Secondary member filter 
 
f) Select an option for analysis model content. Whichever option you choose, you can easily add and remove objects later. 
 Selected parts and loads 
 Full model 
 Floor model by selected parts and loads 
 
g) If you selected parts and loads or Floor model by selected parts and loads, select the parts and loads in the physical model. To 

select the objects, you can use Organizer categories, for example. Note that if you create an analysis model for selected objects 
and then use an analysis model filter to leave out more objects,    you cannot revert to the originally selected objects, even if 
you remove the filtering. 

h) If needed, define other analysis model properties. For example, if you need to run a non-linear analysis, change the analysis 
method on the Analysis tab. 

i) Click OK to create the analysis model. 
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7) Check Which Objects are Included in Analysis Model 
You can check which parts and loads are included in an analysis model. 
a) On the Analysis & design tab, click A&D models. 
b) In the Analysis & Design Models dialog box: 
 Select an analysis model. 
 Click Select objects. 
Tekla Structures highlights and selects the parts and loads in the physical model. 
 
8) Add Objects to in Analysis Model 
 In the physical model, select the parts and loads to add. 
    To select the objects, you can use Organizer categories, for example. 
 On the Analysis & design tab, click A&D models. 
 In the Analysis & Design Models dialog box: 
 Select the analysis model to modify. 
 Click Add selected. 
Tekla Structures adds the selected objects to the selected analysis model. 
 
a) Modify the Properties of an Analysis Model 
 On the Analysis & design tab, click A&D models. 
 In the Analysis & Design Models dialog box: 
 Select the analysis model to modify. 
 Click Properties. 
 
 In the Analysis Model Properties dialog box: 
 Modify the properties. 
 Click OK to save the changes. 
 
b) Define the end releases and Support Conditions 
Before you start, in the Analysis & Design Models dialog box, select the analysis model in which you want to define the part end 
releases and support conditions. 
 Select a part. 
 Right-click and select Analysis Properties. 
 In the part’s analysis properties dialog box: 
 To define the end conditions for the start of the part (yellow handle), go to the Start releases tab. 
 To define the end conditions for the end of the part (magenta handle), go to the End releases tab. 
 In the Start or End list, select an option. 

The options  and  for a pinned part end are shown as dark blue circles close to the analysis part end in the analysis   
model. 

 
 If needed for a supported part end, define the rotation. 
 If needed, modify the translational and rotational degrees of freedom. 
 If you selected Spring for any of the degrees of freedom, enter the spring constant. 
The units depend on the settings in File menu > Settings > Options > Units and decimals. 
 If you selected Partial release for any of the rotational degrees of freedom, specify the degree of connectivity. Enter a value 

between 0 (fixed) and 1 (pinned). 
 Click Modify. 
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c) Create a Rigid Links 
You can create rigid links between analysis nodes. 
 On the Analysis & design tab, click A&D models. 
 In the Analysis & Design Models dialog box, select the analysis model to which you want to add the rigid link. 
 On the Analysis & design tab, click Rigid link. 
 Pick the start point for the rigid link. 
 Pick the end point for the rigid link. 

 
 
d) Remove Objects from an Analysis Model 
You can modify existing analysis models by removing parts and loads from them. 
 In the physical model, select the parts and loads to remove. 
 On the Analysis & design tab, click A&D models. 
 In the Analysis & Design Models dialog box: 
 Select the analysis model to modify. 
 Click Remove selected. 
Tekla Structures removes the selected objects from the selected analysis model. 
 
9) If needed, create alternative or sub-analysis models. 
10) Create a Load Combination 
If needed, you can create load combinations for an analysis model one by one. 
Before you start, ensure that you have the appropriate load modeling code selected in File menu > Settings > Options > Load 
modeling > Current code. 
 On the Analysis & design tab, click A&D models. 
 In the Analysis & Design Models dialog box: 
 Select an analysis model. 
 Click Load combinations. 
 
 In the Load Combinations dialog box, click New. 
 In the Load Combination dialog box: 
 Select a load combination type from the Type list. 
 Enter a unique name for the load combination. 
 Use the arrow buttons to move load groups between the Load groups list and the Load combination table. 
 If needed, modify the signs (+ or -) and combination factors in the Load combination table by clicking a value. 
 Click Apply to create the load combination. 
 If needed, repeat steps a–e to create more load combinations. 
 Click OK to create the last load combination and close the dialog box. 
 In the Load Combinations dialog box, click OK to save the load combinations. 
 
11) Export the analysis model to the analysis application and run the analysis. 
12) If needed, add special loads and other required settings in the analysis application. 
13) If needed, use the analysis application to postprocess the analysis model or analysis results. For example, you can change part 

profiles. After the changes, re-run the analysis. 
14) Import the analysis results to Tekla Structures, examine them, and use them in connection design, for example. 
15) If the analysis results required changes to the model in the analysis application, import the changes to Tekla Structures. 
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III. CONCLUSION 
We will not obtain an accurate analysis if we do not use the software for structural analysis. If software is not used for analysis, we 
must use a traditional method. Traditional techniques take a lot of time and can be mistake-prone in some situations. However, the 
software just provides a thorough examination of the structure and lacks all of this. To do that, the software must be fully aware of 
how to use it; otherwise, problems may also arise. A field worker needs to be proficient in using graphical user interfaces. To 
prevent such issues, this document documents the entire analysis process. 
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