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Abstract: When it comes to automation and smart homes, the Internet of Things (IoT) is a crucial idea in today's world. It has to
do with the automation of things through computing, in which all things and physical devices can be connected in order to make
them sentient and programmable so that they can interact with humans. IoT is a cloud computing network that allows users to
access physical objects or control equipment over a wireless network from any distance, at any time and in any location. One
example of IoT technology is smart home automation. The usage of IoT in smart home automation was completely adopted in
the twenty-first century, according to this study, by guaranteeing that household appliances and equipment were connected. This
sort of IoT design not only controls devices, but also stores sensor data in the cloud and acts on it. The cloud is used to deliver
sensor data via Wi-Fi module, and then a decision tree is applied to determine the output of the electronic devices. IoT-based
services help to improve the domestic environment and are utilised for a variety of purposes. IoT applications based on home
automation are flexible and widely used. This provides access to specific data in the house as well as the ability to control various
parameters remotely. This article details the entire architecture of a smart home automation system based on IoT sensing and
monitoring. The suggested smart home automation system prototype is constructed and tested on hardware in this project,
allowing the user to control a limited number of household appliances using the bylnk application. The NodeMCU (ESP8266)
microcontroller is used, and communication between the microcontroller and the application is done using Wi-Fi (Internet).
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I. INTRODUCTION
Having constantly improving technology is a source of pride for the entire planet. The primary goal of technology is to increase
efficiency while reducing effort. The Internet of Things (IoT) is becoming increasingly important in today's environment. As a
result, automation results in less work and increased efficiency. We have been successful in managing appliances in different sectors
utilising IoT, one of which is home automation control using Node Microcontroller. Another important feature of today's home
automation is the ability to monitor and control automated appliances from afar. With the growth of various communication
technologies such as Wi-Fi and the evolution of smart phones and tablets. The NodeMCU (ESP8266) microcontroller is used, and
communication between the microcontroller and the application is done using Wi-Fi (Internet).
Even when technology advances in our daily lives, no assistance is available for those who are physically unable to benefit from it.
As a speech-enabled system, the home automation system uses voice to control the gadgets. It mostly targets the physically
challenged and the elderly. If the speech recognition is inadequate, the home automation will not work. The user's speech will be
transmitted to the Microphone as input. The person's speech is recognised by the microphone and sent to the recognising module.
Even if there are any interruptions, it searches for the closest word. The action is carried out if the command (ON/OFF) is issued. In
the same way, the line-following robot responds to verbal orders. With the help of sensors and a motor driver board, the linefollowing robot goes forward and backward..
With people through a friendly interface and easily accessible. To achieve the above, another technology that is currently used in
several applications are the embedded systems; these systems consist of free hardware of medium or high performance capable of
solving various electronic and computing problems. These types of systems were implemented in different devices as household
appliances, industrial machines, sensor networks, even in common things such as clothes, vehicles and some medical device.
This study proposes an effective home automation system.
The following are some of the paper's major contributions:
1) At first, we use the readings from numerous sensors put throughout the house to automate the operation of several basic
household appliances like as fans, lights, air conditioners, and water heaters.
2) All of these sensors will be wired to a Node MCU ESP8266 or an Arduino Uno, which will process the sensor data and control
the relays that control the appliances.
3) We can also call the house owner's cell phone to warn them or any alarm monitoring business using this technology.
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II. PROBLEM STATEMENT
Smart home devices are one of the most popular and well-known of all contemporary technological advancements. After all, who
doesn't want to be able to operate their home appliances from their smartphones with just a few taps? People are becoming
increasingly familiar with the usage of smartphones and tablets, which can perform much of the work that a computer can. As a
result, we've chosen to create a low-cost Embedded system that uses smart phones to help automate the entire home. The field of
automation has advanced significantly in industry, with automated assembly lines found in the majority of vehicle and bottling
factories. Everyday life would be made easier if automation were implemented in homes. It can keep track of what's going on inside
and outside our home with a home automation system. These security cameras also capture footage of suspicious passers by on your
property. Smart door locks also enable us to unlock the door remotely for children, the elderly, or visitors when we are not at home.
It will receive real-time alerts on who is entering your home via your Smartphone, even if you are not present.
III. PROPOSED SYSTEM ARCHITECTURE
The planned home automation system's design is shown in the diagram below. Different sensors, such as smoke and flame and
actuators such as buzzers and displays, make up the system. The microcontroller, or main controlling unit, of the Node MCU unit is
the system's main controlling unit. The user sets commands for the appliances' operation using the mobile app. Following the signal,
the Node MCU uses a relay to switch on or off the appliance. Physical connections are made between the Node MCU, relay, and final
appliances. The microprocessor, relay, and final appliances are all powered by a single power supply unit. The state of the application
is also displayed on a display unit.

Fig 1. Block Diagram of Intelligent Home Automation
A. Hardware Components
1) Node MCU: (Node Microcontroller Unit) is an open source IoT platform that is low-cost and easy to use. It started with firmware
and hardware based on the ESP8266 Wi-Fi SoC from Espress if Systems. The ESP32 32-bit MCU was later added to the list of
supported devices. The Web-server for the Home Network was implemented using a NodeMCU ESP8266. According to the
information in Section the Home Network connects to the Internet. The Node MCU is an open-source microcontroller that runs
on an ESP8266, a Tensilica L106 32-bit RISC processor that can be programmed in C via USB. In addition, the Node MCU
provides 1 analog pin and 16 digital pins for input and output activities, which can be used to connect to other devices. The
Ethernet module connects the Home Gateway to the local proxies by acting as a bridge.
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Fig 1.1 NodeMCU (ESP8266)
2) Relay Board:Any appliance linked to a relay works as a switch. Electrical signals are used to provide them with electricity. The
current passing through the coil, which either releases or pulls the bar used to open or close the circuit, drives the circuit's
opening and closing. The microcontroller provides a on or off signal in this project. In the suggested system, a four-channel relay
is implemented, allowing four devices to operate simultaneously.

Fig 1.2. Relay Board
3) Flame Sensor: A flame-sensor is a type of detector that is primarily used to detect and respond to the occurrence of a fire or
flame. The reaction of the flame detector can be affected by the way it is installed. An alarm system, a natural gas line, propane,
and a fire suppression system are all included. In industrial boilers, this sensor is employed. The major purpose of this is to verify
whether or not the boiler is operating properly. Because of the mechanism used to detect the flame, the response of these sensors
is faster and more precise than that of a heat/smoke detector. This sensor/detector can be made with an electronic circuit and an
electromagnetic radiation receiver. The infrared flame flash method is used in this sensor, which allows it to work through a layer
of oil, dust, water vapour, or ice.

Fig 1.3. Flame Sensor
4) Smoke Sensor (MQ-2): The MQ series Gas sensors are the most widely utilised when it comes to measuring or detecting a
specific Gas. These sensors are available as either a module or as a single sensor. Because it comes with an op-amp comparator
and a digital out pin, you can buy it as a module if you only want to detect (not measure ppm) the presence of a gas. However, if
you want to test the ppm of a gas, you should buy the sensor separately (without module). LPG, Alcohol, Propane, Hydrogen,
CO, and even methane can be detected or measured using the MQ-2 Gas Sensor. This sensor's module version has a Digital Pin
that allows it to work without a microcontroller, which is useful when you simply want to detect one gas. The analogue pin must
be used to measure the gas in ppm. The analog pin is TTL driven and works on 5V, thus it can be used with most
microcontrollers.

Fig 1.4. Smoke Sensor (MQ2)
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B. Software
1) Arduino IDE: The Arduino Integrated Development Environment (IDE) is a C and C++-based cross-platform application (for
Windows, Mac OS X, and Linux). Writing code and uploading it to the board is simple with the open-source Arduino Software
(IDE). Any Arduino board can be used with this software. The Arduino Software (IDE) includes a text editor for writing code, a
message area, a text console, a toolbar with buttons for basic functions, and a series of menus. It connects to the Arduino
hardware, allowing it to upload and communicate with programmes.

Fig 2.1. Arduino IDE
2) Blynk: Blynk is a new platform that lets you easily create interfaces to manage and monitor your hardware projects from your
iOS or Android mobile. Blynk may create a project dashboard and organise buttons, sliders, graphs, and other widgets on the
screen after downloading the software.

Fig 2.2 Working Principle of Blynk Application
IV. IMPLEMENTATION
A. Designing
The Web-server for the Home Network was implemented using the NodeMCU ESP8266. The Home Network connects to the Internet
using the information in Section. The Node MCU is an open-source microcontroller that runs on the ESP8266, a 32-bit RISC CPU
that can be programmed in C over USB. For input and output functions, the Node MCU features 1 analog pin and 16 digital pins on
board, which can be used to interact with other devices. The term "Home Automation" refers to the ability to operate lights, climate,
entertainment systems, and appliances without the use of a manual switch. Access control and alarm systems are examples of home
security systems that may be incorporated. Home gadgets are an important component of the Internet of Things when they are
connected to the Internet of things. Home gadgets are an important component of the Internet of Things when they are connected to
the Internet ("IoT"). Using the Blynk application, we will control four home appliances: a television, a fan, a light bulb, a motor, and a
refrigerator that are all connected to a relay. The NodeMCU ESP8266 Wifi Module will receive orders from the smartphone via the
internet. The finest IoT Platform is required to encode the ON/OFF signal and deliver it to the server and the ESP8266 Board. As a
result, we chose Blynk because no other app compares to it. This project requires internet access and cannot be completed without it.
1) Step 1: The Wi-Fi option on the Smartphone is turned on to establish a connection between the client and the server.
2) Step 2: It is connected to the system's Wi-Fi module.
3) Step 3: Connect the digital pins on the Wi-Fi Module to each electronic/electrical appliance in the system.
4) Step 4: Each device is connected to the NodeMCU via a relay, which aids in the conversion of high voltage to low voltage.
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5) Step 5: On the NodeMCU's microprocessor chip, a C-program is loaded that describes what action should be taken when
receiving inputs.
6) Step 6: A Cloud Interface is created, allowing the end user to monitor and control the appliances from anywhere.
7) Step 7: Successful appliance control and monitoring.

Fig 3.1 Circuit Diagram of Intelligent Home Automation
B. Flow Chart
This flow chart depicts the project's workflow. The process starts with the Wi-Fi being set up, then typing in the network name and
password in code and uploading it to the Node MCU. Wi-Fi is used to connect the Android device to the Node MCU. After the Blynk
server is set up and connected, the device is identified in the Blynk server using the created authentication token. The application is
given a command to regulate the load, and this instruction is sent over the Wi-Fi network to the Node MCU.

Fig 3.2 Flow Chart of the system
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C.
1)
a)
b)
c)
d)

Setting up the System
Downloading and installing and Blynk application on smartphone.
The Blynk application is obtained from the Google Play Store and installed.
A new account is generated and logged into after the application is installed.
A new project is created after logging in. The project is given a name, and Node is chosen as the hardware.
Blynk will now send an authentication token to your email address. The hardware in the Blynk server will be identified using this
authentication token.
e) Because the prototype uses a four-channel relay module, four buttons from the side bar are added to the screen.
f) After that, each of the four buttons is personalised by giving it a name and picking the digital pin it will connect to. Because the
relays will be physically connected to the digital pins corresponding to this section, it will have an impact on the hardware
connection.
g) The Blynk application setup is now complete.

Fig 4.1 Set up Bylink Application
2) Driver Installation for Hardware Interfacing.
a) Node MCU Amica is a development board based on the ESP8266 Wi-Fi module. It contains a Micro USB port that can be linked
directly to a computer or other USB host devices. 15X2 header pins and a Micro USB slot are included on the Ti; the headers can
be mounted on a breadboard, and the Micro USB slot is used to connect to a USB host device. It is equipped with a CP2120 USB
to serial converter.
b) The driver for the CP2120 (USB to serial converter) must be downloaded before it can be installed.
c) The system connects to the Node MCU once the user downloads drivers for his or her operating system.
d) The user must node down the COM post assigned to the newly connected USB device (Node MCU) from the system's device
manager. When utilising Node MCU Amica, this com port number will be required.
3) Interfacing Node MCU with Arduino IDE
a) To begin, we'll need to change the board manager with a custom URL using the newest Arduino IDE version. Go to File >
Preferences in the Arduino IDE. Then, at the bottom of the window, paste the following URL into the Additional Board Manager
URLs text box:
b) Then click to Tools > Boards > Boards Manager to get the Board Manager. In addition to the normal Arduino boards, there
should be a few of additional additions. Type esp8266 into the search box to narrow down your results. Select Install from the
drop-down menu next to that entry.
c) Before we begin uploading the sketch and playing with the LEDs, we must first ensure that the board is properly chosen in the
Arduino IDE. Open the Arduino IDE and go to the Tools > Board menu and choose Node MCU 0.9 (ESP-12 Module).
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d) Now, use a micro-B USB cable to connect your ESP8266 NodeMCU to your PC. Once the board is connected, it should be given
its own COM port. This will be something like COM# on Windows PCs, and /dev/tty.usbserial-XXXX Under the Arduino IDE >
Tools > Port menu, select this serial port.

Fig 4.2 Assigning communication port on Arduino IDE
e)

We'll now configure the Arduino IDE by adjusting a few settings. So, go ahead and launch the Arduino IDE. Select 'NodeMCU
1.0 (ESP-12E Module)' as the board under Tools > Board. That's it for the changes we need to make. Now we'll start writing the
code.
f) Select Files > Examples > Blynk > Boards WIFI > ESP8266 Standalone from the Files > Examples > Blynk menu. A new file
opens, containing some prewritten code. The following changes are made to the code.
g) The software is now ready to be installed on the hardware. The code is uploaded to Node MCU when you click the upload
button, and it automatically connects to the given Wi-Fi network the next time it is powered on.
V. APPLICATION
A. Adjust the thermostat while lying in bed or on your way home from work with your phone.
B. On the way home from work, use your smart phone to heat the hot tub or switch on the oven.
C. Turn off all house lights with the push of a single button, eliminating the need to wander around the house turning off lights
before leaving or going to sleep.
D. Set a series of activities for your morning routine, such as setting the thermostat to warm the room, gradually increasing the
intensity of the lighting, and making sure the coffee is brewing and the television is turned on.
E. Set up your security system to send you an e-mail or a phone call if it detects activity in your home while you are gone.
VI. RESULT
The experimental model was constructed in accordance with the circuit schematic, and the results were as predicted. The household
appliances might be controlled remotely via a Wi-Fi network. The control approaches for switch mode were successful. The Blynk
app also worked well in terms of presenting the status of each programme.
VII. FUTURE SCOPE
Given the existing circumstances, we can develop a cross-platform system that can be used on a variety of platforms, including iOS
and Windows. The limitation of being able to control only a few items can be overcome by automating all other home appliances. The
prototype could include sensors to automate the control of home appliances, such as an LDR that detects daylight and switches the
lamp accordingly, a PIR that detects motion and sounds an alarm, or a DHT11 sensor that detects ambient temperature and humidity
and switches the fan/air conditioner accordingly. This project's scope can be expanded to many regions by not limiting it to just the
home, but also to small offices.

©IJRASET: All Rights are Reserved | SJ Impact Factor 7.538 | ISRA Journal Impact Factor 7.894 |

2004

International Journal for Research in Applied Science & Engineering Technology (IJRASET)
ISSN: 2321-9653; IC Value: 45.98; SJ Impact Factor: 7.538
Volume 10 Issue IV Apr 2022- Available at www.ijraset.com
VIII. CONCLUSION
This project has demonstrated that an individual control home automation system can be built inexpensively using low-cost locally
available components and used to control a wide range of home appliances, including security lamps, televisions, air conditioning
systems, and even the entire house lighting system. Even better, the essential components are so small and few that they may be put
in a compact, unobtrusive container. The developed home automation system was tested and certified to operate a variety of home
equipment including lighting, air conditioning, and home entertainment systems, among others. As a result, this system is scalable
and adaptable.
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