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Abstract: Voice Controlled Robotic Vehicle is an example of controlling the bot with the help of daily used voice commands. An 
Android app is used for giving input voice commands and in order to control the motion of robotic vehicle. The voice commands 
given by us is processed by the app and voice module converts speech into text. A controller should be implemented with a 
Bluetooth module through the UART protocol. The converted text commands reach the controller via Bluetooth. The 
microcontroller will process this text and take a necessary action to control the motion of the robotic vehicle. The hardware 
development board used here is Atmega Arduino Board. The software programming part is done in Arduino Ide using 
Embedded C. The objective of the project described in this paper was to regulate the movement of the robotic vehicle using 
commands such as Forward, Backward, Left, Right. There is still a plenty of scope for research and development in the project 
described in this paper. Adding a very small size camera and using http communication protocol we can receive video streaming 
from the camera which is placed on the robotic vehicle. The Robotic vehicle now  can be used for surveillance of  terrorist prone 
areas, suspected areas. 
Keywords: Arduino, Embedded C, Bluetooth, Android. 

I. INTRODUCTION 
The world is growing at a greater pace and in future we can definitely see robots occupying places of humans in work places 
where it is harmful for the human beings to work like chemical factories, factories where machinery is used etc. Now-a-days a 
smart phone is used to control the electronic devices including motors, music, lights etc. In the same way, in this project a smart 
phone with an application installed in it is used for the control of a robotic vehicle with help of voice human voice commands. The 
main components used in the project are an Arduino microcontroller board, L293D Motor Driver, HC05 Bluetooth Module, DC 
Motors. An Android app is used for giving input voice commands and in order to control the motion of robotic vehicle. Voice 
Module converts the voice into text and will send commands to microcontroller via Bluetooth and micro controller based on the 
commands received from the android app controls the movement of the robotic vehicle. Programming Arduino is done in Arduino 
Ide using Embedded C programming language. The prototype will be very helpful to disable people when we use it in wheel chairs 
etc. The embodiment of camera to the robotic vehicle makes it very much useful for surveillance of border areas, terrorist prone 
areas or any other places where there is any doubt about suspicious and illegal activities. 

II. LITERATURE SURVEY 
With reference to press releases by International Federation of Robotics dated September 18, 2019 shows us that there was an 
annual global sales value of 16.5 billion USD in 2018 and 4,22,000 units were shipped globally in 2018 with an increase of 6 
percent compared to the previous academic year. IFR expected an average growth of 12 percent per year from 2020 to 2022. This 
shows us the demand that a robotics industry is having across the world. Many Researchers contributed various research papers 
with respect to the concept and ideology. Some of those papers are mentioned below stating their ideology and implementation 
and technology used. “Vito M Guardi developed the method of communication between an android application and a 
microcontroller with the help of Bluetooth technology. His work showed that a micro controller can take actions from the inputs 
given by an android application”.[1] 
“Ranjith Kumar Goud and B. Santosh Kumar has developed a pick and drop robot for the purpose of diffusing a bomb remotely 
with safety. For the purpose of robotic arm they used a pair of motors and for the purpose of movement they used wheels. The 
communication for the control of robotic arm is done with the help of Bluetooth technology. They used LPC2148 microcontroller. 
They have also embedded a wireless camera for the purpose of surveillance. They have made it mainly to use it for military 
purposes”. [2] 
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“Xiao Lu, Wenjun Liu, Haixia Wang, Qia Sun[3] used internet of things to connect smart phone of Android System to robots 
performing various services using wireless communication, where it is programmed based on TCP socket. The interesting part of 
their project is the robot can sing, dance and so on according to the command and they made the characteristics visual and 
portable.” [3] 
“Mr. K. Kannan and Dr. J. Selvakumar have written a paper that dealt with the existing speech recognition system and its usage in 
their project. They have used EasyVr module which is incorporated in their project to convert the input voice commands given by 
the user into digital values with the help of analog to digital converter (ADC) and compare it with predefined voice commands and 
transmit those values as per the voice commands in the form of binary bits. They have used ATmega 2560, servo motors, ZigBee 
module (at the receiver side) . Based on the binary values received by microcontroller via ZigBee module, servo motors will be 
driven in a continuous loop. The paper helped us to understand about the microcontroller, speech recognition system and its 
disadvantages and the measures to be taken to make the speech recognition system free of errors”.[4] 

III. HARDWARE AND SOFTWARE DESCRIPTION  
A. Hardware Components  
1) Chassis: Chassis is the structural component of our voice controlled Bot. 

 
Chassis 

.It is analogous to the skeleton in living organisms. It supports the load of our voice controlled Bot . It provides the space for all our 
components which includes DC motor, Arduino Board, HC05 Bluetooth module, L293D Motor Driver. In our project voice 
Controlled Bot, we have used two wheel Chassis with a castor wheel at front. 

2) Geared DC Motor  

 
Geared DC Motor 

In our project called Voice controlled Bot ,we have used a DC Motor with a gearbox of 1:120 ratio, here gearbox has a reduction in 
speed, which gives much more power to engine. We fix Rubber wheel with 65mm diameter to this DC Motor. The Motor can drive 
with a input voltage ranging from 3V to 7.5 volts. We supply 5v volts to these DC motors using a Battery from Motor Drivers. With 
a higher voltage within the given range, we can get more output. 
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3) Arduino Uno: Arduino Uno is a Micro-controller Board. It has 14 Digital pins, 6 Analog pins, 16MHz ceramic Resonator, a 
power jack, a USB connection, an ISP header and a reset button. We need to connect our Arduino Board to our Computer using 
USB connector and we need to program it through Arduino IDE. To start our voice controlled bot we can power up the Arduino 
Board using power jack or by USB connection. 

 
Arduino Uno 

4) L293D Motor Driver 

 
L293D Motor Driver 

L293D is a 16 pin Motor Driver IC. It is used to drive motors. L293D IC is capable of driving two DC motors at the same time. 
Direction of the two motors rotation whether in clockwise or anticlockwise can be controlled by passing the signals from Arduino 
Board to the motor driver. Based on the instructions received from the Bluetooth Module, Arduino will send the commands to the 
Motor Driver which are generally logic high or logic low signals. The signals received from the Arduino to the motor Driver are low 
current signals which are insufficient to drive the motors. So motor driver will convert the low current signals to high current signals 
which are capable to drive the motors. 

5) HC05 Bluetooth Module  

 
HC05 Bluetooth Module 

HC05 is a module which allows full duplex wireless Communication. We use this module to have wireless communication between 
our mobile phone and Arduino Board. HC05 module receives text from the Mobile phone where Mobile phone is connected to the 
Bluetooth Module. Then Bluetooth Module communicates with the Arduino Micro-controller with the help of USART at 9600 baud 
rate. Using the Serial Port Protocol ,we pair up the HC05 Bluetooth Module with the Arduino Board.  
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6) ESP-32 Camera Module: The ESP32-CAM is a compact, low-power camera module based on the ESP32 . It features an 
OV2640 camera and a TF card slot onboard.Wireless video surveillance, WiFi image upload, QR identification are some of the 
applications of  ESP32-CAM. Because the ESP32-CAM lacks a USB port, you'll need an FTDI programmer to upload code via 
the U0R and U0T pins (serial pins). 

 
ESP- 32 Camera Module 

Three GND pins and two power pins (3.3V or 5V) are available.The serial pins are GPIO 1 and GPIO 3. These pins are required for 
uploading code to your board. Furthermore, GPIO 0 is critical since it determines whether the ESP32 is in flashing mode or not. The 
ESP32 is in flashing mode when GPIO 0 is connected to GND. 

 
ESP-32 Camera Pinout 

Using an FTDI programmer, connect the ESP32-CAM board to your computer. Take a look at the following schematic diagram: 
A jumper on many FTDI programmers lets you to choose between 3.3V and 5V. Make sure the jumper is in the right place to select 
5V.If you want to upload code, you must connect GPIO 0 to GND. 

 
ESP32 Camera Module connection with FTDI Adapter. 
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B. Software Description 
1) Arduino Voice Control App: This app is developed with the help of MIT app inventor. Using this app, we will connect the 

Mobile phone to our HC05 Bluetooth Module. This arduino voice control app will convert the voice commands into text using 
google assistance. Converted voice commands into text are received by HC05 Bluetooth Module and by serial port protocol 
those texts will received to the arduino micro-controller. 

 
Arduino Voice Control app 

2) Arduino IDE: Arduino Integrated Development Environment is a cross-platform application for Windows, Mac OS, Linux 
written with functions from C and C ++. Used for writing and downloading programs on compatible Arduino boards. Arduino 
IDE supports C and C ++ languages using special coding rules. Arduino IDE provides a software library from the Wiring 
project, which provides many common installation and extraction processes. User-coded code requires only two basic 
functions, starting with the drawing and the main loop system, integrated and linked to the main stub () program in the active 
cyclic executive and GNU tool chain, integrated with IDE distribution. 

 
Arduino IDE 
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IV. WORKING 
 

 

Voice commands are processed over the phone, and the speech-to-text conversion is done within the app using Google's speech to 
text API. The text is then sent to the micrrocontroller via Bluetooth. The text is transmitted to the Arduino Uno board using the 
UART communication protocol Via Bluetooth communication wirelessly. Arduino code checks the received text. Whenever the text 
is the same thread, Arduino controls the robot's movement in a forward, backward, turn right, turn left & stop by sending commands 
to the motor Driver. 

 
Circuit diagram 

Build a video streaming web server with the ESP32-CAM that you may access on your local network by following the steps below. 
To programm the ESP32-CAM board, we utilise the Arduino IDE. As a result, you'll need to have the Arduino IDE installed as well 
as the ESP32 add-on.Go to File > Examples > ESP32 > Camera in your Arduino IDE and open the CameraWebServer example. 

Follow these steps to upload the code: 
1) Go to Tools > Board and select AI-Thinker ESP32-CAM. 
2) Go to Tools > Port and select the COM port the ESP32 is connected to. 
3) Then, click the upload button to upload the code. 
4) Press the ESP32-CAM on-board RST button. 
The code should be successfully uploaded to your board in a few seconds. 

 
Camera WebServer Module 
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A. Getting the IP Address 
1) Disconnect GPIO 0 from GND after uploading the code. 
2) Using a baud rate of 115200, open the Serial Monitor. Press the on-board Reset button on the ESP32-CAM. 
3) The IP address of the ESP32 should be displayed in the Serial Monitor. 

 
IP Address on Serial Monitor 

You can now use your local network to access your camera streaming server. Open a browser, type the IP address of the ESP32-
CAM. To begin streaming video, press the Start Streaming button. 

 
Implemented Model 

V. APPLICATIONS 
A. The project can be used in wide variety of areas such as military, home security, rescue missions, industries, medical assistance 

etc. 
B. The Voice Control Robot is useful for disable people and monitoring purpose.  
C. The size of this robot is small, so we can use this robot for spying purpose. It can be used for surveillance. 
D. Robot controlled by smart phone may be used at the territory for disposal of hidden mines. 

 
VI. FUTURE SCOPE 

The future prospects of this project are as follows: The project can be brought into application in other mobile operating systems 
like ios, windows. Usage of wifi over Bluetooth for the wireless communication between smart phone and microcontroller can 
increase the range to a larger scale. When we use the same prototype in quadcopter we can capture aerial view. 

VII. CONCLUSION 
In this paper we have discussed our approach to create a Arduino Integrated voice controlled Robotic Vehicle that runs with the help 
of an android application installed in the smart phone and we mounted an ESP-32 Camera module which is used for surveillance. 
The system is used for real time application and is secure.  
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